Back to overview
Maintenance

Scheduled Maintenance Notification - ASIC Personal Name Register

May 2, 2026 at 8:00am UTC  –  May 3, 2026 at 8:30am UTC
Affected services
Australia ASIC Personal Name Register

Resolved
May 3, 2026 at 8:30am UTC

Service: ASIC Personal Name Register

Affected Environment: Production

Start Date and Time: 02/05/26 - 08:30 UTC
End Date and Time: 03/05/26 - 08:30 UTC

Issue and Reason: Routine System Maintenance.