Back to overview
Downtime
Unscheduled VEVO Maintenance Notification
Mar 27, 2026 at 10:34am UTC
Resolved
Mar 27, 2026 at 12:44pm UTC
Service is now consistently returning an expected response
Affected services
Created
Mar 27, 2026 at 10:34am UTC
VEVO is experiencing unexpected and intermittent runtime errors
Affected services